ConLite

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Core
  • Assigned To
    Ortwin Pinke
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version ConLite 2.0 RC
  • Due in Version ConLite 2.0.0
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: ConLite
Opened by Ortwin Pinke - 06.07.2015
Last edited by Ortwin Pinke - 06.07.2015

FS#147 - Autoloader: adding class map file a second time causes error

If you add class map file still added before using method addClassmapConfigFile throws error

[06-Jul-2015 14:34:50 Europe/Berlin] PHP Catchable fatal error:  Argument 1 passed to cAutoload::addClassmapConfig() must be of the type array, boolean given, called in /var/www/cl_demo/conlite/classes/class.autoload.php on line 165 and defined in /var/www/cl_demo/conlite/classes/class.autoload.php on line 139

This is caused by using include_once in method which returns 1 as boolean instead of an array if called twice for the same file. Adding a check for array would prevent this message.

Closed by  Ortwin Pinke
06.07.2015 12:43
Reason for closing:  Fixed

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing